2. Configuration NP-View

You are here:
< All Topics

NP-View Java

User interface preferences

The configuration menu of NP-View Java is available under Help > Preferences.

Configuration options include:

  • Font size: to increase the text size in the user interface
  • Invert mouse wheel direction: to change the direction of the mouse wheel when zooming in or out of the topology map
  • Default workspace location: to set the folder that NP-View will use by default when saving files
  • Auto-save project: to automatically save a copy of the current project every 10 minutes
  • Change engine IP or port: NP-View has 2 processes, the user interface and a backend engine. This option allows you to change the IP address (default: 127.0.0.1) and port number (default: 5555) that the backend engine listens on
  • Automatically check for update: to enable NP-View to check if an updated version is available on the portal website (https://portal.network-perception.com)
  • Optimize memory for large project: to reduce some visualization features in the rule audit table so memory can be saved when loading large rulesets (1000+ rules)
  • Increase Java runtime memory: to allocate more memory to the user interface
  • Reset NP-View configuration: to reset all the configuration options to their default value. Be careful: this will also erase your license key and the selection of columns in the rule and path table.

Note: the configuration settings will be stored in the file “np-view.properties” inside the NP-View folder, as well as the Windows registry.

Changing your license key

To upgrade your license key, go to Help > License > Renew your license. This will show a popup window in which you can input your license info and license key. Please make sure to restart NP-View for the new license key to be activated.

Customizing risk alerts

Risk alerts can be customized through the “Risk alerts” option of the Analyze menu. For each risk alert, you can select the severity level (low, medium, high) as well as disabling an alert altogether. You can also create new alerts by following the instructions in the “Learn how to create your own plugins” at the bottom of the risk alert option window.

Updating NP-View Java

The Network Perception team delivers a new general release every quarter. Releases are available for download on the Portal website.

If you have Internet access:

  • If you selected “Check for update when NP-View starts” the first time you installed NP-View, then the application will automatically let you know if a new version is available. You can change that setting in the Help menu under Preferences.

Screenshot

  • From the Help menu, you can also select “Check for update” and a window will show you if a new version is available.

Screenshot

If you are offline:

  • You can compare the version number in the bottom left corner of NP-View with the version number available on the Portal website (Home page > Download Latest Version)

To manually update NP-View:

  1. Go to the Portal website and select “Download Latest Version” from the home page
  2. Download the release of NP-View that matches your operating system (Windows, Mac, or Linux)
  3. Once downloaded, extract the zip file into a new folder
  4. Launch the NP-View executable from that new folder
Table of Contents