2. Configuring NP-View

You are here:
< All Topics

Select your version of NP-View for configuration instructions

NP-View Generation 1 (Java Platform)

User interface preferences

The configuration menu of NP-View Java is available under Help > Preferences.

Configuration options include:

  • Font size: to increase the text size in the user interface
  • Invert mouse wheel direction: to change the direction of the mouse wheel when zooming in or out of the topology map
  • Default workspace location: to set the folder that NP-View will use by default when saving files
  • Auto-save project: to automatically save a copy of the current project every 10 minutes
  • Change engine IP or port: NP-View has 2 processes, the user interface and a backend engine. This option allows you to change the IP address (default: 127.0.0.1) and port number (default: 5555) that the backend engine listens on
  • Automatically check for update: to enable NP-View to check if an updated version is available on the portal website (https://portal.network-perception.com)
  • Optimize memory for large project: to reduce some visualization features in the rule audit table so memory can be saved when loading large rulesets (1000+ rules)
  • Increase Java runtime memory: to allocate more memory to the user interface
  • Reset NP-View configuration: to reset all the configuration options to their default value. Be careful: this will also erase your license key and the selection of columns in the rule and path table.

Note: the configuration settings will be stored in the file “np-view.properties” inside the NP-View folder, as well as the Windows registry.

Changing your license key

To upgrade your license key, go to Help > License > Renew your license. This will show a popup window in which you can input your license info and license key. Please make sure to restart NP-View for the new license key to be activated.

Customizing risk alerts

Risk alerts can be customized through the “Risk alerts” option of the Analyze menu. For each risk alert, you can select the severity level (low, medium, high) as well as disabling an alert altogether. You can also create new alerts by following the instructions in the “Learn how to create your own plugins” at the bottom of the risk alert option window.

Updating NP-View Java

The Network Perception team delivers a new general release every quarter. Releases are available for download on the Portal website.

If you have Internet access:

  • If you selected “Check for update when NP-View starts” the first time you installed NP-View, then the application will automatically let you know if a new version is available. You can change that setting in the Help menu under Preferences.

Screenshot

  • From the Help menu, you can also select “Check for update” and a window will show you if a new version is available.

Screenshot

If you are offline:

  • You can compare the version number in the bottom left corner of NP-View with the version number available on the Portal website (Home page > Download Latest Version)

To manually update NP-View:

  1. Go to the Portal website and select “Download Latest Version” from the home page
  2. Download the release of NP-View that matches your operating system (Windows, Mac, or Linux)
  3. Once downloaded, extract the zip file into a new folder
  4. Launch the NP-View executable from that new folder
NP-View Generation 2 (HTML Platform)

First Login

  • Upon first login, NP-View will require you to create an administrator account. Fill in the required information and click the “Create the NP-View administrator account” button. The password can be as simple or as complex as the user desires but needs to be at least 1 character.
    • Local authentication is for users who wish to add an additional layer of protection. With this, the user can use whatever e-mail address and password they choose. If the user logs out of the system, the user id and password will be required upon subsequent application launches.  Otherwise, the session remains open and authentication is not required.
  • Read and accept the user agreement.
  • Next, you will need to enter your license key. The format of the license key for NP-View Gen II and NP-View Gen I are different. You can request to convert from one to the other by contacting support@network-perception.com. Once input, click the “Add license key” button.
  • Select your preferences for checking for automatic updates (requires internet access) and participation in our voluntary improvement program. Both selections use a slider that is default to on. To deselect, click the button and it will slide the button to the left. Click the save preferences button to complete.
  • Next click the get started button

User Menu

Access to the Help Center, License Manager, Update Manager and other administrative functions can be found on the User Menu located in the top-right corner of the Workspaces page.

Getting Started

On the Workspaces Page,  NP-View II provides a demo workspace as well as the ability to start creating your own workspaces.  To get started, name and create a +New workspace and +Import configuration files. You can also drag and drop configuration files onto the workspace page.

Upgrading from NP-View Gen I to NP-View Gen II

NP-View Gen II can import NP-View Gen I project files that were saved with configuration files.  Simply drag and drop a project file onto the Workspaces page and the import process will automatically begin. Alternatively, the you can create a new workspace and drag and drop the project file into the workspace. NP-View Gen II will parse the configuration files from scratch and render a new topology mal (map locations from NP-View I will not be imported).  Zone configurations and rule comments will also be imported.

Note:  NP-View Gen II files cannot be loaded into NP-View Gen I.

Software Version

If you contact technical support, they will ask you for the software version you are running. It can be found on the bottom left corner of the home screen.

Software Uninstall

To uninstall NP-View II,

  • Windows 10: use the add or remove programs feature to remove the software
    • Use the add or remove programs feature to remove the software
    • Delete folder: ~\AppData\Roaming\NP-View
  • Linux:
    • Remove NP-View program
    • rm -r ~/.config/NP-View
  • macOS:
    • Remove NP-View program
    • Delete folder: ~Library/Application\ Support/NP-View

Password Reset

Remove the file at the location listed below and restart the application to input your credentials.

  • Windows: Delete the file ~\Documents\NPLive\db\auth_provider.cfg and then restart NP-View.
  • Linux: Remove the file ~/.config/NP-View/db/auth_provider.cfg
  • macOS: Remove the file ~Library/Application\ Support/NP-View/db/auth_provider.cfg

License Changes / Upgrades

If you input a new license key from network perception, the user must log out and log back in for the changes to take effect.

Upload File Size Limit

NP-View enforces a maximum file size of 200MB by default. To change it, the config.ini file must be edited and the following row added:  MAX_IMPORT_SIZE=<size in bytes>. For example:  MAX_IMPORT_SIZE=209715200 which corresponds to 200MB.

  • Windows: the config.ini file can be found at:  \Users\<user name>\AppData\Roaming\NP-View\config.ini
  • Linux: the config.ini file can be found at:  ~/.config/NP-View/config.ini
  • macOS: the config.ini file can be found at:  ~Library/Application\ Support/NP-View/config.ini

Next: Training, Workspaces, Reports and Dashboards

Once configured, please proceed to the training section of the Knowledge Base to learn how to use NP-View and NP-Live. After training, please proceed to the Workspaces, Reports and Dashboards section of the Knowledge Base to continue with you NP-View / NP-Live onboarding journey.

Table of Contents